Oct5th

Redmine eclipse-ből

by  connor

Eclipse-hez létezik egy nagyszerű plugin ami segítségével a programból lehet használni a különféle bugtracker programokat (annyira különféléket hogy akár Gmail&calendar-hez is kötni lehet). Ez a plugin a mylyn! A redminehoz is létezik kötés, ezt redmin-mylyncon -nak hívják. Nézzük meg hogyan kell beüzemelni:

Szerver oldal:
ruby script/plugin install https://redmin-mylyncon.svn.sourceforge.net/svnroot/redmin-mylyncon/redmine_mylyn_connector/tags/CURRENT
mv vendor/plugins/CURRENT vendor/plugins/mylyncon
rake db:migrate_plugins RAILS_ENV=production
/etc/init.d/apache2 restart

A ruby hajlamos néha elhasalni az SF terheltsége miatt. –force kapcsolóval adjuk újra ki mindaddig amíg probléma nélkül le nem fut!
Ha mindent jól csináltunk a plugin oldalon megjelenik az új elem.

Ecplise alá pedig a szokásos módon telepítsük innen a plugint:
http://redmin-mylyncon.sourceforge.net/update-site/nightly/

 

5 Responses to Redmine eclipse-ből

  1. 8 years ago by hipi

    Szia connor,

    pont egy ilyen leírást kerestem a neten, hiánypótló, máshol nem találtam így… köszi.
    Fel is ment a telepítés a szerverre.

    Viszont abban tudsz nekem segíteni, hogy kliens oldalon is működésre bírjam?
    A nem túl sokat mondó Server Error hibát írja az Eclipse… 🙁

    A .metadata/.plugins/org.svenk.redmine.core/connectorLog.txt fileban is kb. ennyi infót látok csak :s

    Amit használok: Eclipse 3.5, RESTful plugin

    köszi előre is.


  2. 8 years ago by connor

    Az hogy mi lehet a gond nem tudom. De esetleg tudok segíteni a debuggolásban.
    Mikor repot adsz hozzá az Additional settings részben RESTful legyen kiválasztva.
    Ha még így sem akkor a logokat kell megnézegetni, hogy mihez csatlakozik a program és egyáltalán eléri-e a szervert, azon a redmine-t stb.
    Nálam a teszt gombra kattintva ezt teszi a logokba:
    GET /mylyn/version HTTP/1.1
    Az oldalt meglátogatva ezt kapom:
    <version>
    <plugin major=”2″ tiny=”1″ minor=”5″>2.5.1.stable</plugin>
    <redmine>0.8.5.stable.2903</redmine>
    <rails>2.1.2</rails>
    </version>


  3. 8 years ago by hipi

    Köszi a tippet.
    Igen, RESTful-t használtam és kapcsolódik is a szerverhez. A gond az, hogy nekem a GET /mylyn/version -re következő hibát írja:

    uninitialized constant ActionView::Base::CompiledTemplates::RAILS_GEM_VERSION

    ….

    De sajnos ezzel sem lettem okosabb, Rubyhoz nem sok lövésem van :s
    Google-izás sem ad semmit. 🙁
    Merre folytassam szerinted a debugot?
    Talán rossz verziót használok valamiből?


  4. 8 years ago by connor

    Szinte biztos hogy rossz a verzió. Holnap beposztolom az én verzióimat.


  5. 8 years ago by hipi

    Sikerült megoldani 🙂

    /config/environments/production.rb file-ba kellett felvennem a gem verziót:

    RAILS_GEM_VERSION = ‘1.8’

    Köszi még egyszer!


 

Leave a Reply

Your email address will not be published. Required fields are marked *